Following is a list of Commands available in Morfik Workspace via the Ribbons.


Icon Command Description
hammer_abortcompile16.png Abort Aborts the active compilation process.
help216.png About This option displays information about Morfik.
ImportAccess16.png Access Import Displays Wizard which offers a step by step guide to import data from Access.
bug_yellow16.png Add Breakpoint This option adds a breakpoint at the current line of code.
node_add16.png Add Join Adds a table join to the Relationship.
row_add16.png Add Parameter Adds a new Web Method parameter.
table_add16.png Add Table Adds a table to the Relationship.
table_add16.png Add Tables Add tables to the current Query.
addwatch16.png Add Watch Adds the identifier under the carret to the Watches list.
alignbottom16.png Align Bottom Aligns the bottom edges of the selected controls.
text_align_left16.png Align Left This option aligns to the left the text of the selected control.
text_align_right16.png Align Right This option aligns to the right the text of the selected control.
align16.png Align to Grid This option makes controls snap to an underlying grid in the document.
aligntop16.png Align Top Aligns the top edges of the selected controls.
align16.png Align This option aligns the selected elements in respect to one another.
brush3-16.png Apply Format Applies style information from clipboard to the selected object.
arrow_left_green16.png Back Navigates to the previous location in the Code Editor.
databasebackup16.png Backup Displays Database Backup dialog.
bookmarkrecord16.png Bookmark Bookmarks current record in the dataset.
bug_yellow16.png Breakpoints Show/Hide the Breakpoints panel.
bringforward16.png Bring Forward This option brings forward (in the Z-order) the currently selected objects.
bringtofront16.png Bring to Front This option brings to the front (of the Z-order) the currently selected objects.
text_code_browser16.png Browser Code Displays the browser code view of the current module.
hammerbuild16.png Build Totally rebuilds the current project, recompiling all files.
button16.png Button Inserts a Button control into the current document.
calendar_31-16.png Calendar Inserts a Calendar control into the current document.
bug_yellow16.png Call Stack Show/Hide the Call Stack panel.
navigate_cross16.png Cancel Edit Cancels editing made to the current record of the dataset.
aligncenterh16.png Center Horizontally Centers selected objects horizontally relative to one another.
aligncentreinwindowh16.png Center In Container Horizontal Centers selected objects horizontally within the parent container.
aligncentreinwindowv16.png Center in Container Vertical Centers selected objects vertically within the parent container.
aligncenterv16.png Center Vertically Centers selected objects horizontally relative to one another.
checkbox16.png Checkbox Inserts a Checkbox control into the current document.
cubes16.png Clear Effects Removes all graphical effects from the control.
clearquerygrid16.png Clear Grid Clears all columns from the Query designer.
folder_closeAll16.png Close All This option closes all open documents.
folder_closed16.png Close This option closes the current document.
colors-real-16.png Color Scheme Select a Color Scheme for the current project.
combobox16.png Combobox Inserts a Combobox control into the current document.
hammercompile16.png Compile Compiles the current project.
primarykey16.png Compose Primary Key Adds/Removes selected field from the primary key.
cubes16.png Configure Effects Invokes the Effects dialog allowing the customization of the selected control(s) through the application of visual effects.
container16.png Container Inserts a Container control into the current document.
continue16.png Continue Continues the execution of the current debug process.
convertproject16.png Convert To Language Converts current module to different programming language.
brush3-16.png Copy Format Copies the style information of the selected object to clipboard.
copy16.png Copy Copies the selection from the document and put it on the Clipboard
cpu16.png CPU Debug View Switch Switches to CPU code.
cpu16.png CPU Debug View Displays the CPU debug view.
NewPackageProject16.png Create Package Generates the Package image file for the current project.
cut16.png Cut Cut the selection from the document and put it on the Clipboard.
data_connection16.png Data Connectors Displays the Data Connectors wizard.
data_view16.png Data View Displays the Data view of the current table or query.
datetimeedit16.png DateTime Inserts a DateTimeEdit control into the current document.
bug_yellow16.png Debug Scripts Show the Debug Scripts panel.
bug_yellow16.png Debug Source Show the Debug Source panel.
projectoptions16.png Debugger Options This option displays the Debugger options dialog.
delete2-16.png Delete All This option deletes all the breakpoints in the current project.
column_delete16.png Delete Column Deletes the currently selected column from the Query designer.
navigate_minus16.png Delete Record Deletes the current record from the dataset.
row_delete16.png Delete Row Deletes the currently selected field.
delete2-16.png Delete Deletes the current selection from the document.
deployment16.png Deploy Deploys the application to the Morfik Space.
text_code_design32.png Design Code Displays the design code view of the current widget.
Morfik16.png Design Data Source Open the associated data source in the corresponding designer.
Morfik16.png Design DataSource Opens the associated data source in the corresponding designer.
Morfik16.png Design Sub-Item Open the Sub-Item in the designer.
DesignView16.png Design Table Brings up the designer for this module.
DesignView16.png Design View Frame Displays the design view of the current document.
DesignView16.png Design View Displays the Design view of the current module.
checkboximage16.png Display Record Count Toggles on/off displayng total record count in the dataset.
dropdown16.png Dropdown Inserts a Dropdown control into the current document.
theme16.png Edit Color Theme Displays Color Theme Editor dialog.
font16.png Edit Font Theme Displays Font Theme Editor dialog.
edit-url-16.png Edit URL Displays the edit URL dialog box.
preferences16.png Environment Options Displays the environment options dialog.
Stoptest16.png Errors Show/Hide the Errors panel.
Evaluate16.png Evaluate Modify Displays the content and allows modification of the variable under the carret.
flash-events-16.png Events Displays the events for the the current object.
ExportExcel16.png Excel Export Displays a Wizard which offers a step by step guide to export data to Excel file.
ImportExcel16.png Excel Import Displays a Wizard which offers a step by step guide to import data from Excel.
executionpoint16.png Execution Point Show/Hide the Execution Point in the application being debugged.
exit16.png Exit This option exits the Morfik IDE.
save_as16.png Export Current Theme Displays the Export Theme dialog.
fileuploader16.png File Uploader Inserts a FileUploader control into the current document.
filterdata16.png Filter Data Displays the data Filter dialog.
find_next16.png Find Again Executes repetitive text search.
find16.png Find Declaration Navigates to the declaration of the reference under the caret.
find16.png Find Executes a Text Search.
firebird_connection16.png FireBird Connector Displays the External Firebird connection wizard.
importFirebird16.png Firebird Import Displays a Wizard which offers a step by step guide to import data from an external Firebird database.
fit_to_size16.png Fit to Window Zooms currently selected document to fit the screen.
flashcontrol16.png Flash Inserts a Flash control into the current document.
arrow_right_green16.png Forward Navigates to the next location in the Code Editor.
Report16.png Generate Report Generates the current Report.
Morfik16.png Go to Cursor Highlights current execution line.
gotolastbookmarkrecord16.png Goto Last Bookmark Navigate to the record in the dataset that was previosely bookmarked.
goto16.png Goto Line Number Displays the Goto Line Number dialog.
document_text16.png Header/Footer Toggles Header/Footer for the current document.
help216.png Help Context Displays the index page of the Morfik Wiki.
help216.png Help Index Currently inactive.
home16.png Home Displays the Home screen, with access to recent projects and samples.
document_text16.png HTTP Show/Hide the HTTP monitoring panel.
photo_scenery16.png Image Inserts an Image control into the current document.
index16.png Indexes Display the Table Indexes dialog.
text_code_server16.png Insert Browser Module Creates a new Browser Module in design mode.
column_add16.png Insert Column Inserts a new column in the Query designer.
form16.png Insert Form Creates a new Form in design mode.
text_code_server16.png Insert Module Creates a new Dual Module in design mode.
tables16.png Insert Query Creates a new Query in design mode.
Report16.png Insert Report Creates a new Report in design mode.
row_add16.png Insert Row Inserts a new field.
text_code_server16.png Insert Server Module Creates a new Server Module in design mode.
table16.png Insert Table Creates a new Table in design mode.
gear16.png Insert Web Method Creates a new WebMethod in design mode.
widget16.png Insert Widget Creates a new Widget in design mode.
Morfik16.png Inspect Displays the value of the variable under the carret.
text_code_server16.png Intermediate Source Switch Switches to intermediate source code.
text_code_server16.png Intermediate Source View Displays the intermediate source code.
text_code_javascript16.png JavaScript Switch Switches to the intermediate JavaScript source code.
text_code_javascript16.png JavaScript View Displays the intermediate JavaScript source code.
joinproperties16.png Join Properties Display the Join Properties dialog.
listbox16.png Listbox Inserts a Listbox control into the current document.
lock16.png Lock This option locks the placement of the selected objects within the current document.
NewDocument16.png Log Show/Hide the Log panel.
brush1-16.png Manage Styles Displays the Style Manager dialog.
theme16.png Manage Themes Displays the Theme Manager dialog.
mimetype16.png MIME Types Displays the MIME Types dialog.
projectoptions16.png Morfik Options Displays the Morfik options dialog.
wizardform16.png New Form Wizard Starts a Wizard which helps in creating a new Form.
form16.png New Form Prompts for a name and creates a new Form in design mode.
wizardmodule16.png New Module Wizard Starts a Wizard which helps in creating a new Module.
text_code_server16.png New Module Prompts for a name and creates a new Module in design mode.
package16.png New Package Creates a new Package project.
newpage16.png New Page Displays a dialog to create a new page based on available templates.
NewProjectWizard16.png New Project Wizard Starts a Wizard which offers a step by step guide to creating a new project.
wizardquery16.png New Query Wizard Starts a Wizard which helps in creating a new Query.
tables16.png New Query Prompts for a name and creates a new Query in design mode.
navigate_plus16.png New Record Inserts a new record to the data set.
wizardreport16.png New Report Wizard Starts a Wizard which helps in creating a new Report.
Report16.png New Report Prompts for a name and creates a new Report in design mode.
wizardtable16.png New Table Wizard Starts a Wizard which helps in creating a new table.
table16.png New Table Prompts for a name and creates a new Table in design mode.
NewProject16.png New Web Application Creates a new Web Application with server side built-in database.
wizardwebmethod16.png New Web Method Wizard Starts a Wizard which helps in creating a new Web Method.
gear16.png New Web Method Prompts for a name and creates a new WebMethod in design mode.
widget16.png New Widget Prompts for a name and creates a new Widget in design mode.
tabs16.png Next Tab Cycles through the tabs currently opened in the editor.
Morfik16.png Next Window Cycles through document tabs.
odbc_connection16.png ODBC Connector Displays the External ODBC connection wizard.
odbc_connection16.png ODBC Database Displays a Wizard which offers a step by step guide to import data from external ODBC data source.
odbc_connection16.png OLEDB Database Displays a Wizard which offers a step by step guide to import data from external OLEDB data source.
Morfik16.png Open File At Cursor Opens the file under the caret as a separate document.
Open16.png Open This option opens a new file.
preferences16.png Option Inserts an Option control into the current document.
NewDocument16.png Output Show/Hide the Output panel.
PageBreak16.png Page Break Inserts a Page Break into the current report.
HeaderFooter16.png Page Header/Footer Toggles Header/Footer for the current document.
parameters16.png Page Parameters Displays the Page Parameters dialog box for the page.
page-preview-16.png Page Preview Compiles and displays in the debugger the Page currently active in the editor.
seo-page-16.png Page SEO Displays the dialog box to set properties for Search Engine Optimization (SEO) for the active page.
brush116.png PaintBox Inserts a PaintBox control into the current document.
brush3-16.png Painter Copies the formatting of a visual control to another visual control.
parameters16.png Parameters Form/Report Displays the Form/Report Parameters dialog.
parameters16.png Parameters Page Displays Page Parameters dialog.
parameters16.png Parameters Query Displays the Query Parameters dialog.
clipboard16.png Paste Pastes the contents of the clipboard to the current cursor location.
pause16.png Pause Pauses the execution of the application currently being debugged.
windowdialog16.png Popup Window Inserts a PopupWindow control into the current document.
Subform16.png Preview Form Displays a preview of the current Form.
Morfik16.png Preview Compiles Form or Report and sends it to the browser for viewing.
Morfik16.png Previous Tab Reverse cycles through the different modules currently loaded in the editor.
windowdialog16.png Previous Window Reverse cycles through document tabs.
primarykey16.png Primary Key Sets primary key to the selected field.
printer216.png Print This option prints the current document.
progressBar16.png ProgressBar Inserts a ProgressBar control into the current document.
Morfik16.png Project Filter Allows the user to filter the project view based on object type and name.
projectinfo16.png Project Information Displays the Project Information dialog.
Morfik16.png Project Menu Displays the Project menu.
projectoptions16.png Project Options Displays the project options dialog.
Resources16.png Project Resources Displays the Project Resources dialog.
NewProject16.png Project View Displays the main Project View.
Properties16.png Properties Toggle Object Inspector Show/Hide the Properties panel.
Properties16.png Properties Displays the properties for the the current object.
node_delete16.png Query Remove Join Removes table join from the Query relationship.
rectangle16.png Rectangle Inserts a Rectangle control into the current document.
redo16.png Redo Redoing an action that was undone using the Undo command.
data_refresh16.png Refresh Data Rereads the dataset and updates the Data View.
relationships16.png Relationships Displays the Relationships view for the current project.
node_delete16.png Remove Join Relationship Removes table join from the Relationship.
row_delete16.png Remove Parameter Deletes the currently selected Web Method parameter.
brush1-16.png Remove Style Removes Style information from the control.
table_delete16.png Query Remove Table Removes a table from the Query.
table_delete16.png Remove Table Relationship Removes table from the Relationship.
Morfik16.png Rename Renames the current project item.
replace16.png Replace Executes a Text Replace operation.
HeaderFooter16.png Report Header/Footer Toggles Header/Footer for the current report.
Morfik16.png Reset Layout Resets Panel Layout to default.
exchange16.png Reset Theme Resets all Colors, Fonts and Styles in the current theme to their default values.
Morfik16.png Reset Zoom Resets the zoom level to the default setting for the Project View.
restoredatabase16.png Restore Database Displays the Database Restore dialog.
rssbutton16.png RSS Feeds Displays the RSS Feeds dialog.
rssbutton16.png RSS This option allows editing or creating a new RSS feed in the current project.
run16.png Run Compiles and runs the current project.
SaveAll16.png Save All This option saves all the modified documents.
save_as16.png Save As This option saves the current document with a new name.
ConvertProject16.png Save Project As Displays the Save Project As dialog.
Save16.png Save This option saves the current document.
find16.png Search Show/Hide the Search results panel
Morfik16.png Select All Selects all content in the document.
Morfik16.png Select Activates mouse selection
sendbackward16.png Send Backward This option sends backward (in the Z-order) the currently selected objects.
sendtoback16.png Send to Back This option sends to the back (of the Z-order) the currently selected objects.
text_code_server16.png Server Code Displays the server code view of the current module.
Morfik16.png New Server Project Creates a new Server-Only Application.
Morfik16.png Set As Default Sets the style of the current control as the default for that control type.
table_selection_column16.png Show Columns Displays the Customize Columns dialog.
package16.png Show package contents Displays Package contents in a form similar to the Project View.
sortinggrouping16.png Sorting and Grouping Displays the Sorting and Grouping dialog.
text_code_browser16.png Source View Displays the source view.
alignspaceequallyh16.png Space Equally Along XAxis Aligns the selected objects so they are spaced equally in horizontal direction.
alignspaceequallyv16.png Space Equally Along YAxis Aligns the selected objects so they are spaced equally in horizontal direction.
form16.png Split Horizontally Splits the container in the horizontal direction.
form16.png Split Vertically Splits the container in the vertical direction.
SQL16.png SQL View Displays the SQL view of the current query.
document_text16.png SQL Show/Hide the SQL monitoring panel.
Morfik16.png Statusbar This option toggles the display of the Statusbar.
Step_Into16.png Step Into Steps into the function/procedure being called from the current line of the code.
Step_Out16.png Step Out Continues execution until the end of the current scope.
Step_Over116.png Step Over Steps over the current line of the code.
Stop16.png Stop Interrupts the current debug process.
brush1-16.png Style Toggles the display of the Style panel.
form16.png Subform Inserts a Subform control into the current document.
SubReport16.png Subreport Inserts a Subreport control into the current document.
tabs16.png Tab Order Tab Order
tabs16.png TabControl Inserts a TabControl into the current document.
showtablenames16.png Table Names Shows/Hides the table names in the Query designer.
ExportText16.png Text File Export Displays a Wizard which offers a step by step guide to export data to comma-separated text file file.
ImportText16.png Text File Import Displays a Wizard which offers a step by step guide to import data from comma-separated text file.
textedit16.png TextEdit Inserts a TextEdit control into the current document.
textlabel16.png TextLabel Inserts a TextLabel control into the current document.
thread16.png Threads This option displays a list of all the threads of the currently running application.
timer16.png Timer Inserts a Timer control into the current document.
timer16.png Timers Show/Hide the Timers panel.
bug_yellow16.png Toggle Breakpoint This option toggles a breakpoint in current line of code.
total16.png Totals Shows/Hides the Totals row in the Query designer.
undo16.png Undo Reverses the last editing operation.
brush1-16.png Update Style Updates style definition for the control type that matches the selected control to reflect the current style of that control.
navigate_check16.png Update Record Submits changes made to the current record to the dataset.
ImportAccess16.png View 1:1 Resets the zoom level of the current document to 100% meaning that the document will be displayed in its original size.
text_code_browser16.png View Next Editor Cycles through the different views of the current module.
text_code_browser16.png View Previous Editor Cycles through the different views of the current module.
checkboximage16.png Virtual Mode Toggles on/off the Virtual Mode of the Data View.
bug_yellow16.png Watches Show/Hide the Watches panel.
webservices16.png Web Services Displays the Import Web Services Wizard.
wsdl_connection16.png WSDL Connector Displays the External Web Service connection wizard.
ExportXML16.png XML File Export Displays the Wizard which offers a step by step guide to export data to XML file file.
ImportXML16.png XML File Import Displays a Wizard which offers a step by step guide to import data from XML file.
document_text16.png XML Show/Hide the XML monitoring panel.
zoom16.png Zoom Area Zoom in on a section of the document.
zoomin16.png Zoom in Project Zooms in on the thumbnails displayed in the Project View.
zoom_in16.png Zoom In Zooms in the currently selected document.
zoomout16.png Zoom out Project Zooms out from the thumbnails displayed in the Project View.
zoom_out16.png Zoom Out Zooms out the currently selected document.

Related Topics

Back to top